Contoh Konfigurasi VLAN sederhana

Langsung Dimulai saja yah,

Kita diberi IP 192.168.17.0/27.

Persiapan Jaringan:

  • 3 Router
  • 3 Switch
  • 1 server
  • 6 VLAN

VLAN2 terdiri dari  2PC

VLAN3 terdiri dari 5PC

VLAN4 terdiri dari 3PC

VLAN5 terdiri dari 1PC

VLAN6 terdiri dari 4PC

VLAN7 terdiri dari 7PC

Urutkan terlebih dahulu dari VLAN yang memiliki jumlah host terbesar ke host terkecil. Dalam kasus ini bila diurutkan menjadi:

  1. VLAN7 -> (7 host)
  2. VLAN3 -> (5 host)
  3. VLAN6 -> (4 host)
  4. VLAN4 -> (3 host)
  5. VLAN2 -> (2 host)
  6. VLAN5 -> (1 host)

Kemudian tentukan prefix untuk tiap VLAN berdasarkan jumlah host. Sehingga kita memiliki prefix yang sesuai jumlah host per VLAN yang ingin kita buat, seperti dibawah :

  1. VLAN7 -> (7 host) -> 2^4 => /28
  2. VLAN3 -> (5 host) -> 2^3 => /29
  3. VLAN6 -> (4 host) -> 2^3 => /29
  4. VLAN4 -> (3 host) -> 2^3 => /29
  5. VLAN2 -> (2 host) -> 2^3 => /29
  6. VLAN5 -> (1 host) -> 2^2 => /30

Setelah mendapat prefix untuk tiap VLAN yang telah disesuaikan dengan jumlah host, maka sekarang kita akan mendata ip address untuk setiap VLAN. Mulai dari VLAN yang memiliki jumlah host terbesar hingga jumlah host terkecil.
pembagian IP, Contoh untuk VLAN3 dengan /29 yang dapat menampung 8 IP, maka kita lanjutkan dari IP setelah IP broadcast VLAN sebelumnya (VLAN7) yaitu 192.168.17.14, maka VLAN3 mendapat IP dari 192.168.17.15/29 s/d 192.168.17.23/29 (jarak 8 IP). seperti VLAN7 IP paling awal (192.168.17.15/29) untuk subnetwork dan IP paling akhir (192.168.17.23/29) untuk Brodcast IP. Sisanya IP dari 192.168.17.16/29 s/d 192.168.17.22/29 digunakan sebagai available host yang mungkin untuk dipakai oleh PC pada VLAN3. Lakukan hal yang sama pada VLAN yang lain.

Klik PC yang ingin diisi pada paket tracert kemudia klik Desktop -> IP Configuration -> klik static -> isi ip address -> isi subnetmask -> dan defaul gateway. Default gateway diisi menggunakan IP selain IP yang di assign pada tiap PC dan biasanya IP available paling kecil ataupun yang paling besar pada sebuah subnetwork.

Setting VLAN pada tiap switch :

Masuk ke switch, sebagai contoh kita masuk ke switch yang menangani vlan 6 dan 7 kemudian ketik perintah-perintah berikut:

Switch>enable    (masuk ke mode priviledge)

Switch#vlan database     (masuk ke mode vlan)

Switch(vlan)#vlan 7     (membuat vlan 7)

Switch(vlan)#vlan 6     (membuat vlan 6)

Switch(vlan)#exit     (keluar dari mode vlan)

Switch#configure terminal         (masuk ke mode configurasi global)

Switch(config)#interface range fa0/9 – fa0/12     (masuk ke dalam interface dengan range dari port 9 hingga 12)

Switch(config-if)#switchport mode access   (membuat port di definisikan kedalam anggota vlan)

Switch(config-if)#switchport access vlan 7    (assign port vlan tersebut kedalam vlan 7)

Switch(config-if)#exit   (keluar dari mode Interface )

Switch(config)#interface range fa0/2 – fa0/8     (masuk Interface dari port 2 sampai 8)

Switch(config-if)#switchport mode access     (membuat port di definisikan kedalam anggota vlan)

Switch(config-if)#switchport access vlan 6     (assign port vlan tersebut kedalam vlan 7)

Untuk perintah interface range hanya bisa dipakai bila pada port yang ingin kita assign ke dalam VLAN tertentu berurutan, ini dapat sangan mempermudah dari pada harus assign satu-per-satu port. Saran ane, jadi sebaiknya buat port berurut untuk sebuah VLAN seperti port VLAN diatas. Selanjutnya lakukan hal yang sama untuk untuk semua VLAN dengan kondisi disesuaikan VLAN terkait.

Lanjut,  Buat port dengan mode trunk untuk dilalui oleh VLAN. Truking berfungsi untuk melewatkan beberapa VLAN hanya dengan satu jalur. pada contoh diatas jalur trunking dipakai untuk jalur dari switch port fa0/1 ke router port fa0/0 :

Switch(config)#interface fa0/1     (masuk ke dalam interface fast ehternet 0/1)

Switch(config-if)#switchport mode trunk     (membuat port menjadi mode atau jalur trunk)

untuk mengecek apakah port telah menjadi port trunking coba hover (arahkan kursor tanpa diklik) ke ke switch terkait. bila port yang di assign sebagai mode trunk telah berubah tanda dari vlan1 menjadi – – pada coloum VLAN maka port telah menjadi jalur trunk.

lakukan hal yang sama pada switch lain untuk membuat jalur trunk pada tiap switch.

VLAN routing pada router

Setelah semua VLAN di buat sesuai kebutuhan serta telah diassign/ didefinis port-port nya pada VLAN masing masing, dan juga telah dibuatkan jalur trunking pada switch. Sekarang kita harus membuat subinterface pada router.

Tujuannya agar kita dapat menghemat port pada router. Karena dengan subinterface memungkinkan kita untuk melewatkan beberapa VLAN lewat satu port pada router. caranya:

klik router yang ingin kita setup. Contoh disini ane setup untuk router2 untuk VLAN7 dan VLAN6

router>enable          (masuk ke priviledge command )

router#configure terminal         (masuk ke configurasi global)

router(config)#interface fa0/0.7         (masuk fast-ethernet 0/0 dengan subinterface id 6)

router(config-subif)#encapsulation dot1q 7

router(config-subif)#ip address 192.168.17.14 255.255.255.240        (memasukan ip gateway dari VLAN 7 ke subinterface fa0/0.7)

router(config-subif)#exit        (keluar dari subinterface saat ini)

router(config)#interface fa0/0.6        (masuk fast-ethernet 0/0 dengan subinterface id 6)

router(config-subif)#encapsulation dot1q 6

router(config-subif)#ip address 192.168.17.30 255.255.255.240       (memasukan ip gateway dari VLAN 6 ke subinterface fa0/0.6)

router(config-subif)#exit          (keluar dari subinterface saat ini)

router(config)#interface fa0/0          (masuk ke fastethernet 0/0 karena ini merupakan port diatas subinterface fa0/0.6 dan fa0/0.7)

router(config-if)#no shutdown         (menyalakan port/ UP/ enable)

Menentukan IP Antar Router

setalah kita set pada router untuk dapat melakukan inter VLAN routing, maka tugas kita sekarang adalah untuk memasukan IP untuk jalur dari router menuju router yang melewati port serial. caranya:

  • Untuk jalur dari router ke router kita hanya akan memakan 2 ip maka kita pakai prefix /30 (submask : 255.255.255.252)
  • sebagai contoh kita gunakan router0 dan router1, IP terakhir dipakai adalah oleh VLAN5 dengan ip : 192.168.17.51/30. Maka untuk jaringan router0 dan router1 ip yang kita gunakan kita lanjutkan menjadi 192.168.17.52/30 s/d 192.168.17.55/30.
  • kita tahu 192.168.17.52/30 adalah ip network dan 192.168.17.52/30 adalah ip broadcast, maka sisa dari range tersebut yaitu ip 192.168.17.53/30 dan 192.168.17.54/30 merupaka usable ip addres yang dapat kita assign untuk port serial baik router0 maupun router1.
  • sekarang kita masukan 2 ip tersebut keport serial dikedua router (router0 dan router2), caranya:

router0>enable

router0#configure terminal

router0(config)#interface se0/0/0

router0(config-if)#ip address 192.168.17.53 255.255.255.252

router0(config-if)#clock rate 64000       (clock rate ditaruh pada port yang ada gambar jam)

router0(config-if)#no shutdown

sekarang pindah ke router1, dan ulangi langkah seperti router0,

router1>enable

router1#configure terminal

router1(config)#interface se0/0/0

router1(config-if)#ip address 192.168.17.54 255.255.255.252

router0(config-if)#no shutdown

sekarang ulangi langkah yang sama untuk router1 port se0/0/1 dan router2 untuk port se0/0/0 dan jangn lupa untuk enable port dengan perintah no shutdown.

nyuplik dari sini

 

1 Response to “Contoh Konfigurasi VLAN sederhana”


  1. 1 Dini Novianti March 27, 2016 at 10:03 pm

    kalau routernya pake cabel cross konfig ya gimana ya antar vlan dalam routernya ?


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s





%d bloggers like this: